PDA

View Full Version : Coralife 65G HOB Super Skimmer



5ft24
03-04-2014, 06:33 PM
Had this SS since August. Been running great. Clean the pump monthly to ensure no algae buildup, etc. A month ago, i noticed the bubbles were larger and not so many. Not pulling any skimmate into the cup. Checked the air silencer and removed it in case it was plugged. No change. Pulled the pump, no real gunk, cleaned, used a piece of paperclip to make sure the air hole in the intake screen was clear, put it back together. Same thing. Yanked the whole skimmer, gave it the vinegar cleaning, cleaned all plumbing inside with brushes etc, put it back in and gave it a week to settle. Same thing. Found out if i put a little suction on the airline, and pull a little water up in it, then blow out the water and blow more air into the pump, it works great for between an hour and 2 days, then the bubbles drop back again. The volume of the water going thru appears the same as before.
Any suggestions?

mfinn
03-05-2014, 10:27 AM
I was hoping someone would respond to this yesterday.
I have never had one of these skimmers, I have only read about the problems they have and the one you seem to be experiencing seems common.
Most people say to make sure the air line is clear. That is usually where salt build up happens.
You said you cleaned everything? I would take another look at the airline, maybe with very hot water.
Then I would look at the impeller. The pump impeller is one of the weak points on any skimmer. That may need changing.

This may be a good time to invest in a better skimmer.
They are on the low end.

5ft24
03-05-2014, 10:41 AM
I was hoping someone would respond to this yesterday.
I have never had one of these skimmers, I have only read about the problems they have and the one you seem to be experiencing seems common.
Most people say to make sure the air line is clear. That is usually where salt build up happens.
You said you cleaned everything? I would take another look at the airline, maybe with very hot water.
Then I would look at the impeller. The pump impeller is one of the weak points on any skimmer. That may need changing.

This may be a good time to invest in a better skimmer.
They are on the low end.

I've run hot water under pressure thru the airline, used wire to clean the air intake hole in the front screen, pulled the impeller and cleaned it, the magnet, the bore of the pump body, the ceramic axle etc. Doesn't look like there is any wear on the impeller. I really want to drill the tank for an overflow and add a sump. Then I can get a real skimmer...

Sent from my SCH-I535 using Tapatalk

makeme1098
03-05-2014, 02:02 PM
I had this skimmer years ago and had the same issue. I eneded up putting an airpum attached to the hose and it worked ok.

5ft24
03-05-2014, 07:36 PM
I had this skimmer years ago and had the same issue. I eneded up putting an airpum attached to the hose and it worked ok.

I'll give that a shot... Least expensive fix!

Sent from my SCH-I535 using Tapatalk

5ft24
03-12-2014, 07:47 PM
Fixed. I had soaked the venturi in vinegar and scrubbed it quite a few times with no luck. Finally put it in hot water to soften the air hose and removed it. Couldn't get a toothpick thru the hole. Used a straightened paperclip to punch the crud out, soaked it in vinegar for an hour, made sure all the gunk was gone and reinstalled it. Works better than it did new!

Sent from my SCH-I535 using Tapatalk