AirWaterIce <----> Clear Fabrications
Results 1 to 9 of 9

Thread: BiocubeRapid LED Dimmer Help!

  1. #1
    New Forum member!

    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    10
    Rep Power
    0

    BiocubeRapid LED Dimmer Help!

    Ah,

    So I just bought a 14 gallon biocube with 12 cree rapidled retrofitted hood from a RF member. Lights are dimmable but only with one driver.

    Everything was working fine for the first couple days, but the light's dimmer suddenly stopped working today.
    I had it on about 75%, and it just dimmed itself to maybe about 15%. The LEDs will still dim down further and shut off, but they refuse to turn any brighter.

    I'm still really new to LEDs but I spent all day yesterday and today reading up on it, and can't figure it out. Maybe the driver is just defective?
    Any suggestions or advice would greatly be appreciated!

    Thank You!

  2. #2
    tat2z_21

    tat2z_21's Avatar
    Join Date
    Jan 2008
    Location
    Gilbert, AZ
    Posts
    1,993
    Rep Power
    67
    I would check the input voltage coming from the dimmer. If it is not 10vdc you will not get the full brightness. If that is right then I would check to see if there is corrosion built up on any of the contacts.
    Olduvai Theory - This is a one-shot affair. If we fail, this planetary system fails so far as intelligence is concerned. The same will be true of other planetary systems. On each of them there will be one chance, and one chance only.

    Hidden Content

    Hidden Content

  3. #3
    New Forum member!

    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    10
    Rep Power
    0
    Hmm yeah, thats what I was thinking, it just seems odd that it was working fine this morning and now it isn't.. I don't have an ohm reader though so can't figure it out..Just frustrated I'm already having problems less than a week in..can't seem to figure out the problem.

  4. #4
    New Forum member!

    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    10
    Rep Power
    0
    Ah I should probably also add that one of the blues is burnt out so that only 11 are functioning... could that be an issue? thanks

  5. #5
    tat2z_21

    tat2z_21's Avatar
    Join Date
    Jan 2008
    Location
    Gilbert, AZ
    Posts
    1,993
    Rep Power
    67
    Definitely a problem. Right now if it is still getting a ground it probably has a large amount of resistance. Try routing a wire around the burnt out one.
    Olduvai Theory - This is a one-shot affair. If we fail, this planetary system fails so far as intelligence is concerned. The same will be true of other planetary systems. On each of them there will be one chance, and one chance only.

    Hidden Content

    Hidden Content

  6. #6
    copod
    Join Date
    Dec 2009
    Location
    Everett, WA
    Age
    56
    Posts
    2,557
    Rep Power
    0
    +1 on above advice from Floyd, re-route or replace emitter and all should be good. If it's a centrally located LED you might even replace it with another color if not already a mix. ie: if only Cool White and Royal Blues add a Green/Cyan, Violet or regular Blue.

    Cheers, Todd

  7. #7
    New Forum member!

    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    10
    Rep Power
    0
    hm.. sounds good guys, I will try to figure out this whole soldering process tomorrow, and hope it works! thanks

  8. #8
    tat2z_21

    tat2z_21's Avatar
    Join Date
    Jan 2008
    Location
    Gilbert, AZ
    Posts
    1,993
    Rep Power
    67
    I would not run your lights, until this gets fixed. The reason for that is it could cause all LEDs to burn up. Just my thought.
    Olduvai Theory - This is a one-shot affair. If we fail, this planetary system fails so far as intelligence is concerned. The same will be true of other planetary systems. On each of them there will be one chance, and one chance only.

    Hidden Content

    Hidden Content

  9. #9
    tat2z_21

    tat2z_21's Avatar
    Join Date
    Jan 2008
    Location
    Gilbert, AZ
    Posts
    1,993
    Rep Power
    67
    Were you able to get it fixed?
    Olduvai Theory - This is a one-shot affair. If we fail, this planetary system fails so far as intelligence is concerned. The same will be true of other planetary systems. On each of them there will be one chance, and one chance only.

    Hidden Content

    Hidden Content

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •