BarrierReef <----> Sierra Fish & Pets
Page 8 of 8 FirstFirst ... 5678
Results 106 to 116 of 116

Thread: Jabao pumps

  1. #106
    Emerald Crab

    Join Date
    Feb 2007
    Location
    kelso ,wa
    Age
    39
    Posts
    297
    Rep Power
    0
    I have a wp-40 love it don't need any other pumps in the 75g all the sps are happy and good flow and for $57 shipped to me in 3 days all I say is wow

    Sent from my HTCEVOV4G using Tapatalk
    Brandon

  2. #107
    Cleaner Shrimp

    Join Date
    Aug 2011
    Location
    seattle
    Posts
    362
    Rep Power
    0
    Finally ordered 2 wp60 with the dual controller, ordered from fish st
    Can't wait I feel like a kid, I guess Christmas in September lol

  3. #108
    Cleaner Shrimp

    Gryphon's Avatar
    Join Date
    Apr 2013
    Location
    Federal Way
    Posts
    354
    Rep Power
    0
    I have two WP25s in my 90g, love them!

  4. #109
    Cleaner Shrimp

    Join Date
    Aug 2011
    Location
    seattle
    Posts
    362
    Rep Power
    0
    I'm currently using one wp40 and a tunze for my 180, looks ok flow wise but with everything growing I will soon need more flow, then I will have the wp40 for my future 75 frag tank, my wp40 is been running for about 11 months without any issues to say the least I'm very happy with the performance

  5. #110
    I Love Big Torts!
    Aquanaut's Avatar
    Join Date
    Feb 2005
    Location
    Renton, WA
    Age
    51
    Posts
    519
    Rep Power
    91
    I just installed THREE RW-15 units on my 250g from the first local shipment at OCEANS BY DESIGN. Not sure if I'll install a fourth unit I opted to get for a sweet deal or save for another tank. I'm loving the surge/flow running full speed and not throwing water yet either, lol.

    Anyone know why in a master to slave mode the slave units don't mimic the night mode function as expected ex. master is in the main roomlight and the slaves are remoted to a utility closet, so, with night mode activated the slaves enter and stay in night mode while the master is in room light normal mode?

    Aquanaut, Renton WA
    Hidden Content

    Hidden Content

  6. #111
    Cleaner Shrimp

    Join Date
    Aug 2011
    Location
    seattle
    Posts
    362
    Rep Power
    0
    Wooo hooo got my 2 new wp60, looking good, wow these things are powerful, so far I like them

  7. #112
    Cleaner Shrimp

    Gryphon's Avatar
    Join Date
    Apr 2013
    Location
    Federal Way
    Posts
    354
    Rep Power
    0
    I'm thinking about getting the JBWave controller.

    http://www.amazon.com/JBWave-Wavemak...eywords=JBWave

  8. #113
    Cleaner Shrimp

    Join Date
    Aug 2011
    Location
    seattle
    Posts
    362
    Rep Power
    0
    Well today my Jebao wp40 quit working, out the blue it just stopped, i tried a new power supply and nothing, it only lasted 1 year 3 months and a few days, glad i kept my Tunzes
    Better luck next time lol

  9. #114
    Sea Urchin
    tike's Avatar
    Join Date
    Mar 2005
    Location
    Tacoma,WA
    Posts
    1,915
    Rep Power
    117
    I wonder what others experience with these pumps are. Ever since they came out I wondered about there longevity. I never pulled the trigger on getting one because my vor tech's have run strong for 8+ years now.

  10. #115
    RF Staff
    spieszak's Avatar
    Join Date
    Oct 2012
    Location
    Seattle
    Posts
    1,716
    Rep Power
    100
    I've had my wp40 since 2012. Going strong.
    I swapped the 40 into another tank maybe a year and a half ago and moved to two wp25's to add a little more flow and they have been running strong also. I did have one of the wp25's die, and I replaced it.. but the day before it went out, I had moved some stuff and put stress on the cord.. pretty sure I caused the problem there.
    I've been completely happy with them, and haven't seen any perceptible change in performance.
    -Stacey
    30 gallon nem tank /60 gallon softie tank/75 mixed reef /5 gallon pico (work tank)
    Hidden Content

  11. #116
    Surgeonfish
    mfinn's Avatar
    Join Date
    May 2004
    Location
    Olympia, WA
    Posts
    6,958
    Rep Power
    177
    Quote Originally Posted by seedlessinseattle View Post
    Well today my Jebao wp40 quit working, out the blue it just stopped, i tried a new power supply and nothing, it only lasted 1 year 3 months and a few days, glad i kept my Tunzes
    Better luck next time lol
    I've seen a lot of posts like this on several different forum.
    But as long as they are cheap, people will continue to buy them saying they can't afford pumps like Tunze and Vortechs.

    I have several Tunze's that are 10+ years old and still working.
    I wonder how many Jeboas I'd have to buy to last 10 years?

Page 8 of 8 FirstFirst ... 5678

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •