Quantcast

PinPoint pH Monitor

Help Support Reef Frontiers:

Abissus

New in Hobby
Joined
Feb 8, 2004
Messages
105
Location
Redmond, WA
I have one that is not working. I don't know if I just need a new probe, I can turn it on and the reading is just gibberish. Also I cannot see the number unless viewing at a steep angle (except the period in the middle, that is very clear). I see the same garbage with or without the probe.

Anyone knows where I can get it repair?

Thanks.
 

NaH2O

Well-known member
Joined
Jan 25, 2004
Messages
8,568
This might sound silly, but I need to ask....if the monitor is run on a battery? If not, try plugging it in away from the tank. Also, has the probe dried out? You could try sending American Marine (makers of Pinpoint) an email.

American Marine
 

cubalz

Member
Joined
Feb 25, 2004
Messages
17
Location
Magnolia, Delaware
Sounds like an LCD issue with the display or if you are running it on 9v power try replacing the battery. If you plug it in to the wall as I have then it sounds like the display is shot. I would imagine that it would be just as cheap to replace the whole unit than getting it fixed.
 

DonW

R.I.P.
Joined
Dec 15, 2003
Messages
8,753
Location
Tacoma, WA
Take it apart, you need a small phillips screw driver. Pull out the display. The back is flat, clean it. Give it a shot worked for me. You can also buy the display at radio shack (special order about $20).

Don
 

Abissus

New in Hobby
Joined
Feb 8, 2004
Messages
105
Location
Redmond, WA
Thanks. I went to American Marine's site and read the manual, sounds like the probe should be kept wet all the time and mine is definitely not.

I guess I might as well pitch the whole thing, just replacing the probe is $45 :(

Maybe I'll email them and see if they can tell if just the probe is shot.

Thank you very much for all your help.

Joyce
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.
Top