Quantcast

Snails & Polyps Hurting

Help Support Reef Frontiers:

FishBoyNB

Well-known member
Joined
Nov 1, 2003
Messages
59
Location
North Bend, Washington
Hi all,

Got home from work this evening to find all of my snails TU on the bottom of the tank. Also the few polyps I have are closed up tight.

Fish seem OK.

Ammonia/Nitrate/Nitrite are 0

pH is about 8.2

Temp is about 82

Any thoughts?

Thanks,

Dan
 

NeilsReef

Well-known member
Joined
May 17, 2004
Messages
182
Location
Troutdale, Oregon
Just curious have you added anything recently that may have a trace of copper? I have heard of people who have added rock to their tanks, that previously was used in a FOWLR, where copper was used in that tank to combat diseases. In these tanks the rock can absorb the copper in to it, and it can be difficult to remove. This probably doesn't apply here, but I thought I would throw it out, just for fun.
 

FishBoyNB

Well-known member
Joined
Nov 1, 2003
Messages
59
Location
North Bend, Washington
Nothing new....

Just back from Blue Sierra. Had them test my water just to make sure I wasn't somehow screwing that up. Same results there.

No new additons in the last ten days or so, and the last thing was just a few mushrooms.

Water is RO/DI. SG is 1.025.

Some of the snails are now up and around now, but the polyps are still closed up.

May do a 10% change tomorrow after work.

Thanks,

Dan
 

MarineDreamer

Est. April 2nd, 2005
Joined
Mar 2, 2004
Messages
492
Location
Granite Falls, Wa
Is 82 where you normally keep the temp? Just wondering if with Sunshine in our area if the tank heated up and somethings didn't like it......

Just grabbing the first straw that I saw. Hopefully it's not the short one!

Trevor
 
Your email address will not be publicly visible. We will only use it to contact you to confirm your post.

Latest posts

Top